码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 10815 Andy's First Dictionary

时间:2015-04-12 09:17:50      阅读:108      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

Problem B: Andy‘s First Dictionary

Time limit: 3 seconds


技术分享

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

Joke and image taken from the Web

输入一个文本,找出所有不同单词(连续的字母序列),按字典序从小到大输出,单词不区分大小写。

就是用set,不过有个大坑,一开始不明所以的wrong了,看了一个大神的博客才明白的,就是

输入345abc6d时 要输出

abc

d

这是那位大神的博客http://blog.csdn.net/u014705854/article/details/42918317

下面贴下代码。

#include<iostream>
#include<string>
#include<set>
#include<cctype>
#include<iterator>
using namespace std;
int main()
{
	set<string>dict;
	string s;
	while (cin >> s)
	{
		string temp = "";
		int p = 0;
		for (int i = 0; i < s.length(); i++)
		{		
			if (isalpha(s[i]))
			{
				p = 1;
				if (s[i] >= 'A'&&s[i] <= 'Z') s[i] = s[i] + 32;
				temp = temp + s[i];
			}
			else 
			{
				if (p)   // p==1 表示前面输入的是字母  p==0 表示前面输入的不是字母 
				{
					dict.insert(temp);
					p = 0;
					temp = "";
				}
			}
		}
		if (p)
		dict.insert(temp);
	}
	for (set<string>::iterator it = dict.begin(); it != dict.end(); it++)
		cout << *it << endl;
}


UVA - 10815 Andy's First Dictionary

标签:

原文地址:http://blog.csdn.net/qq_18738333/article/details/44999835

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!