Time Limit: 10 Sec Memory Limit: 256 MB
Submit: 153 Solved: 52
[Submit][Status][Discuss]
Description
Input
第一行一个正整数,表示数据组数据 ,接下来T行
每行三个正整数N,K,P
Output
T行,每行输出一个整数,表示结果
Sample Input
1
1 2 3
Sample Output
1
HINT
Source
By Wcmg
数论难题。
首先我们设矩阵
看到题目中的式子,我们可以想到二项式定理,即
上面的式子与所求式是不是很像?只要再加一句
我们的目的是构造一个数组
【题中说了
那么只有当
【证明】:
①
②
根据等比数列求和公式,这个式子变成了
于是题中的式子就可以等价为
而上面的式子又是什么呢?
我们设
而
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#define LL long long
using namespace std;
struct matrix
{
LL f[3][3];
}T;
LL n,k,p;
int y[1000000],cnt;
LL Pow(LL a,LL n)
{
LL b=a%p,ans=1;
while (n)
{
if (n&1) ans=ans*b%p;
b=b*b%p;
n>>=1;
}
return (ans%p+p)%p;
}
matrix Add(matrix a,matrix b)
{
matrix ans;
for (int i=0;i<2;i++)
for (int j=0;j<2;j++)
ans.f[i][j]=(a.f[i][j]+b.f[i][j])%p;
return ans;
}
matrix Mult(matrix a,matrix b)
{
matrix ans;
for (int i=0;i<2;i++)
for (int j=0;j<2;j++)
{
ans.f[i][j]=0;
for (int k=0;k<2;k++)
ans.f[i][j]=(ans.f[i][j]+a.f[i][k]*b.f[k][j]%p)%p;
}
return ans;
}
matrix Pow_mult(matrix b,LL n)
{
matrix ans;
int f=0;
while (n)
{
if (n&1)
{
if (f) ans=Mult(ans,b);
else ans=b,f=1;
}
b=Mult(b,b);
n>>=1;
}
return ans;
}
LL Calc(LL x)
{
matrix ans;
ans.f[0][0]=ans.f[1][1]=x;
ans.f[0][1]=ans.f[1][0]=0;
ans=Add(ans,T);
ans=Pow_mult(ans,n);
LL nix=Pow(Pow(x,n),p-2);
for (int i=0;i<2;i++)
for (int j=0;j<2;j++)
ans.f[i][j]=ans.f[i][j]*nix%p;
return ans.f[0][0];
}
void Getyinshu(int n)
{
for (int i=2;i<=sqrt(n);i++)
{
if (n%i) continue;
y[++cnt]=i;
if (n/i>i) y[++cnt]=n/i;
}
}
bool Judge(int x)
{
for (int i=1;i<=cnt;i++)
if (Pow(x,y[i])%p==1) return false;
return true;
}
LL Getw()
{
Getyinshu(p-1);
int g;
for (g=2;;g++)
if (Judge(g))
break;
return Pow(g,(p-1)/k);
}
int main()
{
int t;
cin>>t;
while (t--)
{
cnt=0;
T.f[0][0]=T.f[0][1]=T.f[1][0]=1,T.f[1][1]=0;
scanf("%lld%lld%lld",&n,&k,&p);
LL w=Getw();
LL ans=0;
LL ni=Pow(Pow(w,k-1),p-2);
ans=(ans+Calc(ni))%p;
for (int i=k-2;i>=0;i--)
{
ni=ni*w%p;
ans=(ans+Calc(ni))%p;
}
cout<<(ans*Pow(k,p-2)%p+p)%p<<endl;
}
return 0;
}
这道题首先想到二项式定理;
然后利用
原文地址:http://blog.csdn.net/regina8023/article/details/45007551