码迷,mamicode.com
首页 > 其他好文 > 详细

单调队列优化DP

时间:2015-04-12 11:58:11      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6277    Accepted Submission(s): 2289


Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. 
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 

 

Sample Input
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 

 

Sample Output
7 1 3 7 1 3 7 6 2 -1 1 1
 

 

Author
shǎ崽@HDU
 

 

Source
 
 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<set>
using namespace std;
#define INF 100000000
int tt,n,k;
int sum[200005],a[200005],hd,ed;
int main()
{
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d%d",&n,&k);
        int j=n;
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
        }
        for(int i=n+1;i<n+k;i++)
        {
            sum[i]=sum[i-1]+a[i-n];
        }
        n=n+k-1;
        int ans=-INF;
        deque<int> q;
        q.clear();
        for(int i=1;i<=n;i++)
        {
            while(!q.empty()&&sum[i-1]<sum[q.back()])//维护单调性
                q.pop_back();
            while(!q.empty()&&q.front()<i-k)
                q.pop_front();
            q.push_back(i-1);
            if(sum[i]-sum[q.front()]>ans)
            {
                ans=sum[i]-sum[q.front()];
                hd=q.front()+1;
                ed=i;
            }
        }
        if(ed>j)
            ed=ed%j;
        printf("%d %d %d\n",ans,hd,ed);
    }
    return 0;
}

  

单调队列优化DP

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4419159.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!