码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ刷题(1092)

时间:2015-04-12 16:18:34      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:hodj   acm   算法   

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74414    Accepted Submission(s): 39738

Problem Description
Your task is to Calculate the sum of some integers.
 
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 
Sample Input
4 1 2 3 4 5 1 2 3 4 5 0
 
Sample Output
10 15
 

程序(已经accepted):
#include <stdio.h>

int main()
{
    int n, number, sum;
    while(scanf("%d", &n), n)
    {
        sum = 0;
        while (n--)
        {
            scanf("%d", &number);
            sum += number;
        }
        printf("%d\n", sum);
    }
    return 0;
}
执行时间:
技术分享

HDOJ刷题(1092)

标签:hodj   acm   算法   

原文地址:http://blog.csdn.net/xumesang/article/details/45010183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!