码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ刷题(1093)

时间:2015-04-12 17:54:05      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:hodj   acm   算法   

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55226    Accepted Submission(s): 37126

Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 
Sample Input
2 4 1 2 3 4 5 1 2 3 4 5
 
Sample Output
10 15
 

程序(已经accepted):
#include <stdio.h>

int main()
{
    int line, number, sum, n;
    scanf("%d", &line);
    while(line--)
    {
        sum = 0;
        scanf("%d", &n);
        while(n--)
        {
            scanf("%d", &number);
            sum += number;
        }
        printf("%d\n", sum);
    }
    return 0;
}
运行时间:
技术分享

HDOJ刷题(1093)

标签:hodj   acm   算法   

原文地址:http://blog.csdn.net/xumesang/article/details/45010347

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!