码迷,mamicode.com
首页 > 其他好文 > 详细

Poj 3279 Fliptile 【枚举】

时间:2015-04-12 19:23:51      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:枚举

Fliptile

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4161 Accepted: 1585

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

USACO 2007 Open Silver

题意:有一个M*N的长方形,每个位置都有一个点(要么是白色或黑色),点击这个点会将它连同周围连着的点都翻转过来,问能不能用最少的点击数,使得这个图全白色。
分析:可以发现只要我们确定了第一行的放置后面的就可以确定了。 一个位置最多可以翻转一次,翻转两次就等于没翻转。所以我们最后只需要统计最后的翻转次数就好了,如果有相同的翻转次数那么就输出字典序最少了那个!因为第一行有N个点,每个点都有两个状态,所以就有1<

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
const int MAX = 25;
using namespace std;

int tile[MAX][MAX], flip[MAX][MAX], ans[MAX][MAX], N, M;
const int dx[] = {0, 0, 0, 1, -1};
const int dy[] = {1, -1, 0, 0, 0};

int get(int x, int y){//是判断有几个需要改变的
    int c = tile[x][y];
    int xx, yy;
    for(int i = 0; i < 5; ++ i){
        xx = x + dx[i]; yy = y + dy[i];
        if(xx >= 0&& xx < M&& yy >= 0&&yy < N)
            c += flip[xx][yy];
    }
    return c&1;
}

int cal(){ //计算某个状态是否可以满足条件,如果是可以返回翻转次数,否则返回-1
    for(int i = 1; i < M; ++i){
        for(int j = 0; j < N; ++ j){
            if(get(i-1, j)) //根据左上角潘多
                flip[i][j] = 1; //如果需要改变的是奇数,那么就需要将这个点需要的次数变为1
        }
    }
    for(int j = 0; j < N; ++j){//判断最后一行
        if(get(M-1, j)) return -1;
    }
    int res = 0;
    for(int i = 0; i < M; ++ i)
        for(int j = 0; j < N; ++ j)
            res += flip[i][j];
    return res;
}

void solve(){
    int upp = (1<<N);//总的状态,然后枚举
    int res = -1;
    for(int i = 0; i < upp; ++i){
        memset(flip, 0, sizeof(flip));//初始化
        for(int j = 0; j < N; ++ j){
            flip[0][j] = (i>>j)&1;//j或N-1-j都行
        }
        int num = cal();
        if(num >= 0&&(res < 0|| res > num)){
            res = num;
            memcpy(ans, flip, sizeof(flip));
        }
    }
    if(res == -1) printf("IMPOSSIBLE\n");
    else{
        for(int i = 0; i < M; ++i){
            printf("%d", ans[i][0]);
            for(int j = 1; j < N; ++ j)
            printf(" %d", ans[i][j]);
            printf("\n");
        }
    }
}

int main(){
    while(scanf("%d%d", &M, &N) == 2){
        for(int i = 0; i < M; ++ i){
            for(int j = 0; j < N; ++ j)
                scanf("%d", &tile[i][j]);
        }
        solve();
    }
    return 0;
}

Poj 3279 Fliptile 【枚举】

标签:枚举

原文地址:http://blog.csdn.net/shengweisong/article/details/45012655

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!