码迷,mamicode.com
首页 > 其他好文 > 详细

Sicily 13983. Milk Scheduling

时间:2015-04-13 09:32:47      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:sicily

13983. Milk Scheduling

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Farmer John has N cows that need to be milked (1 <= N <= 10,000), each of which takes only one unit of time to milk.

Being impatient animals, some cows will refuse to be milked if Farmer John waits too long to milk them. More specifically, cow i produces g_i gallons of milk (1 <= g_i <= 1000), but only if she is milked before a deadline at time d_i (1 <= d_i <= 10,000). Time starts at t=0, so at most x total cows can be milked prior to a deadline at time t=x.

Please help Farmer John determine the maximum amount of milk that he can obtain if he milks the cows optimally.

Input

* Line 1: The value of N.

* Lines 2..1+N: Line i+1 contains the integers g_i and d_i.

Output

* Line 1: The maximum number of gallons of milk Farmer John can obtain.

Sample Input

4
10 3
7 5
8 1
2 1

Sample Output

25

Hint

In the sample, there are 4 cows. The first produces 10 gallons of milk if milked by time 3, and so on. Farmer John milks cow 3 first, giving up on cow 4 since she cannot be milked by her deadline due to the conflict with cow 3. Farmer John then milks cows 1 and 2.

Problem Source

2015年每周一赛第六场

按照g大优先、d小优先排序,对于一个奶牛,优先放到尽量靠近d的时间点,这样尽可能的延后,给了其他的奶牛充分的时间……

#include <iostream>
#include <algorithm>
using namespace std;

struct cow {
	int g, d;
	cow(int g = 0, int d = 0) {
		this->g = g;
		this->d = d;
	}
};

bool cmp(const cow & c1, const cow & c2) {
	if (c1.g == c2.g) return c1.d < c2.d;
	else return c1.g > c2.g;
}

cow c[10005];
bool used[10005];

int haveTime(int d) {
	for (int i = d; i > 0; i--) if (!used[i]) return i;
	return 0;
}

int main() {
	std::ios::sync_with_stdio(false);

	int n;
	cin >> n;
	for (int i = 0; i < n; i++) cin >> c[i].g >> c[i].d;
	sort(c, c + n, cmp);
	int t = 4, ans = 0;
	for (int i = 0; i < n; i++) {
		int feedDay = haveTime(c[i].d);
		if (feedDay) {
			used[feedDay] = true;
			ans += c[i].g;
		}
	}
	cout << ans << endl;

	return 0;
}

Sicily 13983. Milk Scheduling

标签:sicily

原文地址:http://blog.csdn.net/u012925008/article/details/45016855

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!