标签:acm c++ 杭电 算法 编程
Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 164592 Accepted Submission(s): 38540
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
水题 不愿意 连续刷了 ,改换算法题。
第一个题目就从dp下了手,感觉第一次不太好理解。
分析找出了状态转移方程d【i】=max{d[i-1]+a[i],a[i]}; 意思是以第i个元素结尾的子序列的值或着a【i】两者的最大值。并在状态转移的过程中时刻更新各个状态d【i】中的最大值那么每一个d【i】都是以i结尾的子序列最大值,因为a【i】如果加上与前一个元素i-1结尾的子序列最大值d【i-1】,那么为了使d【i】最大,如果a【i】+d【i-1】是大于0的那么必然要加上,否则还不如不加,还么a【i】大呢。
AC:
#include<iostream>
using namespace std;
int main()
{
int n,T,num,sum,maxn,s,e,temp;int t=0;
cin>>T;
while(T--)
{
sum=0;
maxn=-101;
s=e=temp=1;
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>num;
sum+=num;
if(sum>maxn)
{
maxn=sum;
e=i;
s=temp;
}
else if(sum<0)
{
sum=0;
temp=i+1;
}
}
cout<<"Case "<<++t<<":"<<endl
<<maxn<<" "<<s<<" "<<e<<endl;
if(T)
cout<<endl;
}
return 0;
}
这个代码 不知道怎么记录位置 以后在解决
杭电 HDU ACM 1003 Max Sum
标签:acm c++ 杭电 算法 编程
原文地址:http://blog.csdn.net/lsgqjh/article/details/45013673