码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2051

时间:2015-04-13 12:36:36      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8457    Accepted Submission(s): 6552

Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1 2 3
Sample Output
1 10 11
Author
8600 && xhd
Source
Recommend
linle
解题:输出二进制数
    #include <stdio.h>
    int main()
    {
        int b[11], n, i;
        while (~scanf("%d", &n))
        {
            i = 0;
            while(n)
            {
                b[i++] = n % 2;
                n /= 2;
            }
            i--;
            while(i >= 0)
                printf("%d", b[i--]);
            printf("\n");
        }
        return 0;
    }

 

hdu 2051

标签:

原文地址:http://www.cnblogs.com/biong-blog/p/4421619.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!