码迷,mamicode.com
首页 > 其他好文 > 详细

(记忆化搜索) hdu 5151

时间:2015-04-13 16:27:32      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:

Sit sit sit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 238    Accepted Submission(s): 114


Problem Description
There are N chairs in a row and and no one on the chairs.Each chair is blue or red.Then comes N students one by one numbered 1,2,3,..,N.For each student, he will find an empty chair to sit on.He won’t sit on the chair if the chair is satisfied the following three conditions.

1.The chair has both left and right adjacent chairs.
2.The left and right adjacent chairs are not empty.
3.The left and right adjacent chairs’ color are different.
If the current student can’t find a chair to sit on, he will go away.

For each student, he may have many choices of chairs to sit on. Your task is to find the number of distinct situations that all students have sat on a chair. As the answer can be rather large, find remainder after dividing the number by 1000000007(109+7).
 

 

Input
There are several test cases.
In each test case:
The first line contains a integer N(1N100).The second line contains N integers.Each integer is either 0 or 1.Integer 0 means blue and 1 means red.
 

 

Output
For each test case, output the remainder of division of the resulting number by 1000000007(109+7).
 

 

Sample Input
3 1 0 0 4 1 0 0 1
 

 

Sample Output
4 8
 

 

Source
 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;
#define LL long long
#define MODER 1000000007
LL n,a[105],dp[105][105],c[105][105];
void fun()
{
    c[0][0]=1;
    c[1][0]=1;
    for(int i=1;i<=100;i++)
    {
        c[i][i]=1;
        c[i][0]=1;
        for(int j=1;j<i;j++)
        {
            c[i][j]=(c[i-1][j]+c[i-1][j-1])%MODER;
        }
    }
}
LL dfs(int l,int r)
{
    if(dp[l][r]!=-1)
        return dp[l][r];
    if(l==r) return dp[l][r]=1;
    dp[l][r]=(dfs(l+1,r)+dfs(l,r-1))%MODER;
    for(int k=l+1;k<r;k++)
    {
        if(a[k-1]!=a[k+1])
            continue;
        dp[l][r]=(dp[l][r]+dfs(l,k-1)%MODER*dfs(k+1,r)%MODER*c[r-l][k-l]%MODER)%MODER;
    }
    return dp[l][r]%MODER;
}
int main()
{
    fun();
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(dp,-1,sizeof(dp));
        printf("%I64d\n",dfs(1,n)%MODER);
    }
    return 0;
}

  

(记忆化搜索) hdu 5151

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4422264.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!