码迷,mamicode.com
首页 > 其他好文 > 详细

(传递闭包) hdu 3357

时间:2015-04-13 20:44:58      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:

Stock Chase

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1410    Accepted Submission(s): 436


Problem Description
I have to admit, the solution I proposed last year for solving the bank cash crisis didn’t solve the whole economic crisis. As it turns out, companies don’t have that much cash in the first place.
They have assets which are primarily shares in other companies. It is common, and acceptable, for one company to own shares in another. What complicates the issue is for two companies to own shares in each other at the same time. If you think of it for a moment, this means that each company now (indirectly) controls its own shares.
New market regulation is being implemented: No company can control shares in itself, whether directly or indirectly. The Stock Market Authority is looking for a computerized solution that will help it detect any buying activity that will result in a company controlling its own shares. It is obvious why they need a program to do so, just imagine the situation where company A buying shares in B, B buying in C, and then C buying in A. While the first two purchases are acceptable.
The third purchase should be rejected since it will lead to the three companies controlling shares in themselves. The program will be given all purchasing transactions in chronological order. The program should reject any transaction that could lead to one company controlling its own shares.
All other transactions are accepted.
 

 

Input
Your program will be tested on one or more test cases. Each test case is specified on T + 1 lines. The first line specifies two positive numbers: (0 < N <= 234) is the number of companies and (0 < T <= 100, 000) is the number of transactions. T lines follow, each describing a buying transaction. Each transaction is specified using two numbers A and B where (0 < A,B <= N) indicating that company A wants to buy shares in company B.
The last line of the input file has two zeros.
 

 

Output
For each test case, print the following line:
k. R
Where k is the test case number (starting at one,) R is the number of transactions that should be rejected.
Note: There is a blank space before R.
 

 

Sample Input
3 6 1 2 1 3 3 1 2 1 1 2 2 3 0 0
 

 

Sample Output
1. 2
 

 

Source
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
int n,m;
bool mp[300][300];
void update(int x,int y)
{
    mp[x][y]=true;
    for(int i=1;i<=n;i++)
    {
        if(mp[i][x])
            mp[i][y]=true;
    }
    for(int i=1;i<=n;i++)
    {
        if(mp[y][i])
        {
            mp[x][i]=true;
            for(int j=1;j<=n;j++)
            {
                if(mp[j][y])
                    mp[j][i]=true;
            }
        }
    }
}
int main()
{
    int x,y,cnt=0;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
            break;
        int ans=0;
        memset(mp,0,sizeof(mp));
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            if(x==y) ans++;
            else if(mp[y][x]) ans++;
            else if(!mp[x][y])
            {
                update(x,y);
            }
        }
        printf("%d. %d\n",++cnt,ans);
    }
    return 0;
}

  

(传递闭包) hdu 3357

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4423063.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!