码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1081To The Max

时间:2015-04-13 20:59:33      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8992    Accepted Submission(s): 4359


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
15
 

Source
Greater New York 2001


最大连续子串和:

有串s,用一个临时变量t维护一个ans,若t>=0则加上s[i]可能会更好,于是有t+=s[i],
若t<0,则变成s[i]可能会更好,于是有t=s[i]
每次若大于ans,更新即可

最大子矩阵和:

有矩阵s,用一个临时数组a维护一个ans,每次a都记录s连续i行矩阵的和,
这样就可以当作最大连续子串处理,每次算出最大值更新ans,即可

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
using namespace std;
int a[110],pic[110][110];
int n;
int sub()
{
	int ans=INT_MIN,t=0;
	for(int i=0;i<n;i++)
	{
		if(t>=0)
			t+=a[i];
		else
			t=a[i];
		ans=max(ans,t);
	}
	return ans;
}
int matrix()
{
	int ans=INT_MIN;
	for(int i=0;i<n;i++)
	{
		memset(a,0,sizeof(a));
		for(int j=i;j<n;j++)
		{
			for(int k=0;k<n;k++)
				a[k]+=pic[j][k];
			ans=max(ans,sub());
		}
	}
	return ans;
}
int main()
{
	while(cin>>n)
	{
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
				cin>>pic[i][j];
		cout<<matrix()<<endl;
	}
}


hdu1081To The Max

标签:

原文地址:http://blog.csdn.net/stl112514/article/details/45030727

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!