码迷,mamicode.com
首页 > 其他好文 > 详细

Robberies

时间:2015-04-13 22:28:01      阅读:536      评论:0      收藏:0      [点我收藏+]

标签:

A - Robberies
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 

技术分享

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input

3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output

2 4 6
 题解:用不被抓到的概率来处理,状态转移方程相对简单。把可能抢到的钱数所对应的不被抓住的概率存入dp数组,再for(i=sum;i>=0;i++)如果能抢到的最大钱数所对应的不被抓概率大于(1-p)则输出i,然后跳出循环,该i值为最大钱数

 

 代码:
#include<stdio.h>
double max(double a,double b)
{
    return a>b?a:b;
}
int main()
{
    int t,n,M[110],i,j,sum;
    double p,P[110],dp[10010];   //dp为背包最大容量
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%lf%d",&p,&n);
        dp[0]=1;              //当抢到的钱为零时,不被抓的概率为1
        for(i=0; i<n; i++)
        {
            scanf("%d%lf",&M[i],&P[i]);
            sum+=M[i];
        }
        for(i=1; i<=sum; i++)     //需将除dp[0]以外的所有元素初始化为零,因为状态转移方程要比较大小再赋值,见图。之前错在此处。
            dp[i]=0.0;
        for(i=0; i<n; i++)              //此循环为遍历银行
            for(j=sum; j>=M[i]; j--)     //此处不易理解。假设银行(1,0.02)(2,0.03)(3,0.05)  此循环大概功能:dp[6]=dp[3]*P[3],dp[3]=dp[1]*P[2].
                dp[j]=max(dp[j],dp[j-M[i]]*(1-P[i]));    //状态转移方程
        for(i=sum; i>=0; i--)
            if(dp[i]>=(1.0-p))
            {
                printf("%d\n",i);
                break;
            }
    }
    return 0;
}

  技术分享

Robberies

标签:

原文地址:http://www.cnblogs.com/jasonlixuetao/p/4423247.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!