码迷,mamicode.com
首页 > 其他好文 > 详细

ACM-树状数组之Stars——hdu1541,poj2352

时间:2014-06-08 16:52:38      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:acm   树状数组   stars   hdu1541   poj2352   

***************************************转载请注明出处:http://blog.csdn.net/lttree***************************************



Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4129    Accepted Submission(s): 1632


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

bubuko.com,布布扣

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
1 2 1 1 0
 

题目:

HDOJ:    http://acm.hdu.edu.cn/showproblem.php?pid=1541

POJ:        http://poj.org/problem?id=2352



又是一道树状数组,要注意题目求的是 每个等级星星的个数。

并不是第i个星星的等级。

等级判别:只要该星星左下方(包括正下方和正左方,不包括自己)有几个星星,等级就是几。


用树状数组的原理,三个函数一上,就出来了。

因为坐标是从0开始,所以相应的坐标要+1操作,否则会崩溃的。


/*******************************************
********************************************
*           Author:Tree                    *
*    From :  blog.csdn.net/lttree          *
*      Title : Stars                       *
*    Source: hdu 1541                      *
*      Hint :  树状数组                    *
********************************************
********************************************/

#include <stdio.h>
#include <string.h>
#define RANGE 32005

// star存等级数,c存星星
int c[RANGE],star[15001];

int lowbit( int x )
{
    return x&(-x);
}
void add( int i )
{
    while( i<=RANGE )
    {
        ++c[i];
        i+=lowbit(i);
    }
}
int sum( int i )
{
    int sum=0;
    while( i>0 )
    {
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}
int main()
{
    int n,i,x,y;
    while( ~scanf("%d",&n) )
    {
        memset(star,0,sizeof(star));
        memset(c,0,sizeof(c));

        for ( i=0;i<n;i++ )
        {
            scanf("%d%d",&x,&y);
            // 坐标是从0开始的,所以x+1
            star[sum(x+1)]++;
            // 后执行add函数,否则会把当前的星星算进去
            add(x+1);
        }
        for( i=0;i<n;i++ )
            printf("%d\n",star[i]);
    }
    return 0;
}



ACM-树状数组之Stars——hdu1541,poj2352,布布扣,bubuko.com

ACM-树状数组之Stars——hdu1541,poj2352

标签:acm   树状数组   stars   hdu1541   poj2352   

原文地址:http://blog.csdn.net/lttree/article/details/28616789

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!