码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1102 Constructing Roads (裸的并查集)

时间:2014-06-08 03:22:29      阅读:289      评论:0      收藏:0      [点我收藏+]

标签:iaccepted   并查集   最小生成树   hdu   1102   

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13210    Accepted Submission(s): 4995


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 

题目意思:有n个村庄,编号1-n,以矩阵的形式给出任意两个村庄之间的距离,然后告诉已经有q个村庄已经修好了路,问现在要打算使所有村庄都联通需要修路的最小长度。

思路就是构造一棵最小生成树,所以将距离排序,从小到大依次并入,直到集合数为1为止。


#include <cstdio>
#include <cstdlib>
#include <vector>
#include <algorithm>

using namespace std;

const int MAXX = 102;

typedef struct Road{
	int x, y, dist;
	Road(int ix, int iy, int idist){
		x = ix;
		y = iy;
		dist = idist;
	}
}road;

int n,roads,length;
vector<road> vec;

int pre[MAXX];
bool yes[MAXX][MAXX] = { 0 };

void init(int n){
	for (int i = 1; i <= n; ++i){
		pre[i] = i;
	}
}

int root(int x){
	if (x != pre[x]){
		pre[x] = root(pre[x]);
	}
	return pre[x];
}

bool merge(int x, int y){
	int fy = root(y);
	int fx = root(x);

	bool mark = false;

	if (fx != fy){
		pre[fx] = fy;
		mark = true;
		--roads;
	}

	return mark;
}

bool cmp(road a, road b){
	return a.dist < b.dist;
}

int main(){

	//freopen("in.txt", "r", stdin);
	int dist, t, x, y;

	while (scanf("%d", &n) != EOF){
		roads = n - 1;
		vec.clear();
		memset(yes, 0, sizeof(yes));

		for (int i = 1; i <= n; ++i){
			for (int j = 1; j <= n; ++j){
				scanf("%d", &dist);
				if (i == j || i > j)continue;//重复的路径不进行添加
				vec.push_back(road(i, j, dist));
			}
		}

		sort(vec.begin(), vec.end(), cmp);

		init(n);

		scanf("%d", &t);

		while (t--){
			scanf("%d %d", &x, &y);
			merge(x, y);
			yes[x][y] = true;
		}

		length = 0;
		vector<road>::iterator ite = vec.begin();
		for (; ite != vec.end() && roads != 0; ++ite){
			x = (*ite).x;
			y = (*ite).y;
			dist = (*ite).dist;
			if (yes[x][y])continue;
			if (merge(x, y))length += dist;
		}

		printf("%d\n", length);
	}
	return 0;
}



HDU 1102 Constructing Roads (裸的并查集),布布扣,bubuko.com

HDU 1102 Constructing Roads (裸的并查集)

标签:iaccepted   并查集   最小生成树   hdu   1102   

原文地址:http://blog.csdn.net/iaccepted/article/details/29220347

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!