码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4586 Play the dice(概率题,推公式)

时间:2015-04-14 16:38:23      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:acm   概率 hdu   

Problem Description:

There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What‘s more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.

Input:

Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers ai(0<=ai<200)
The second line is an integer m (0<=m<=n), following with m integers bi(1<=bi<=n), which are the numbers of the special sides to get another more chance.

Output:

Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.

Sample Input:

6 1 2 3 4 5 6
0
4 0 0 0 0
1 3

Sample Output:

3.50
0.00


解题思路:

当n == m时,输出inf, 不然结果就是 sum / (n - m);

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#define LL long long
using namespace std;
const int MAXN = 1000 + 10;
int main()
{
    int sum, n, m;
    while(scanf("%d", &n)!=EOF)
    {
        sum = 0;
        int x;
        for(int i=0;i<n;i++)
        {
            scanf("%d", &x);
            sum += x;
        }
        scanf("%d", &m);
        for(int i=0;i<m;i++)
            scanf("%d", &x);
        if(sum == 0)
        {
            printf("0.00\n");
            continue;
        }
        if(n == m)
        {
            printf("inf\n");
            continue;
        }
        printf("%.2lf\n", (double)sum / (n - m));
    }
    return 0;
}


HDU 4586 Play the dice(概率题,推公式)

标签:acm   概率 hdu   

原文地址:http://blog.csdn.net/moguxiaozhe/article/details/45043811

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!