码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3210 A Stack or A Queue?

时间:2015-04-14 16:48:47      阅读:96      评论:0      收藏:0      [点我收藏+]

标签:zoj      namespace   algorithm   acm算法   


I - A Stack or A Queue?
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Do you know stack and queue? They‘re both important data structures. A stack is a "first in last out" (FILO) data structure and a queue is a "first in first out" (FIFO) one.

Here comes the problem: given the order of some integers (it is assumed that the stack and queue are both for integers) going into the structure and coming out of it, please guess what kind of data structure it could be - stack or queue?

Notice that here we assume that none of the integers are popped out before all the integers are pushed into the structure.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then Ttest cases follow.

Each test case contains 3 lines: The first line of each test case contains only one integer N indicating the number of integers (1 <= N<= 100). The second line of each test case contains N integers separated by a space, which are given in the order of going into the structure (that is, the first one is the earliest going in). The third line of each test case also contains N integers separated by a space, whick are given in the order of coming out of the structure (the first one is the earliest coming out).

Output

For each test case, output your guess in a single line. If the structure can only be a stack, output "stack"; or if the structure can only be a queue, output "queue"; otherwise if the structure can be either a stack or a queue, output "both", or else otherwise output "neither".

Sample Input

4
3
1 2 3
3 2 1
3
1 2 3
1 2 3
3
1 2 1
1 2 1
3
1 2 3
2 3 1

Sample Output

stack
queue
both
neither


水题,栈和队列处理一下就好,

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
int ans;
int b[205];
#include <queue>
#include <stack>
int main()
{
    char s[305][305];
    char s1[305];
    int i,j;
    int n,m;
    int ans=0;
    int t;
    int flag,flag1;
    cin>>t;
    while(t--)
    {
        queue<int>q;
        stack<int >Q;
        int n;
        cin>>n;
        for(i=0; i<n; i++)
        {
            scanf("%d",&m);
            q.push(m);
            Q.push(m);
        }
        flag=1;
        flag1=1;
        for(i=0; i<n; i++)
        {
            scanf("%d",&m);
            if(m!=q.front())
                flag=0;
            if(m!=Q.top())
                flag1=0;
            q.pop();
            Q.pop();
        }
        if(flag  &&flag1)
        {
            cout<<"both"<<endl;
        }
        else if(flag &&!flag1)
        {
            cout<<"queue"<<endl;
        }
        else if(!flag &&flag1)
        {
            cout<<"stack"<<endl;
        }
        else
            cout<<"neither"<<endl;
    }


}


ZOJ 3210 A Stack or A Queue?

标签:zoj      namespace   algorithm   acm算法   

原文地址:http://blog.csdn.net/sky_miange/article/details/45042501

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!