码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3555 Bomb [数位]

时间:2015-04-15 09:45:42      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:

Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output

For each test case, output an integer indicating the final points of the power.
 

Sample Input

3 1 50 500
 

Sample Output

0 1 15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
         



Analyse:

同 “不要62”,数位模板!!

但是脑残,,,,dp没开long long;

Code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<string>
#include<queue>
#include<deque>
#include<stack>
#include<map>
#include<set>
#define INF 0x7fffffff
#define SUP 0x80000000
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;

typedef __int64 LL;
const int N=100007;
LL dp[30][10][2];
int digit[30];

LL dfs(int pos,int pre,int en,int limit)
{
    if(pos==-1) return en;
    if(!limit&&dp[pos][pre][en]!=-1) return dp[pos][pre][en];
    int last=limit?digit[pos]:9;
    LL ret=0;
    for(int i=0;i<=last;i++)
    {
        ret+=dfs(pos-1,i,en||(pre==4&&i==9),limit&&i==last);
    }
    if(!limit) dp[pos][pre][en]=ret;
    return ret;
}

LL solve(LL x)
{
    int cnt=0;
    while(x)
    {
        digit[cnt++]=x%10;
        x/=10;
    }
    return dfs(cnt-1,0,0,1);
}

int main()
{
    int T;scanf("%d",&T);
    LL n;
    mem(dp,-1);
    while(T--)
    {
        scanf("%I64d",&n);
        printf("%I64d\n",solve(n));
    }
    return 0;
}



HDU 3555 Bomb [数位]

标签:

原文地址:http://blog.csdn.net/code_or_code/article/details/45048681

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!