码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 1022 Train Problem I 【顺序栈】

时间:2014-06-08 05:27:01      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:数据结构   顺序栈   

最近打算重新看一边数据结构,昨天看的时候感觉栈这部分部分能看懂了。 于是就赶紧来实践一下!!

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19493    Accepted Submission(s): 7305


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can‘t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can‘t exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
3 123 321 3 123 312
 

Sample Output
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can‘t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 
#include<stdio.h>
#include<stdlib.h>
int main()
{
	int n;
	char a[50], b[50], s[50];//s相当于栈
	int flag[50], top;    //top是栈顶
	while( ~scanf( "%d %s %s", &n, a, b ) )
	{
		top = -1;
		int i = 0, k=0, j = 0;
		while( i < n )
		{
			s[++top] = a[i++];
			flag[++k] = 1;//enter stack
			while( top!=-1&&s[top] == b[j] ) 
			{
				flag[++k] = 0; //out stack
				top--;
				++j;
			}
		}
		if( j == n )
		{
			puts("Yes." );
			for( i = 1; i <=k; i ++ )
			if( flag[i] )
			printf( "in\n" );
			else
			printf( "out\n" );
		}
		else
		puts( "No." );
		puts("FINISH" );
	}
	return 0;
}



hdoj 1022 Train Problem I 【顺序栈】,布布扣,bubuko.com

hdoj 1022 Train Problem I 【顺序栈】

标签:数据结构   顺序栈   

原文地址:http://blog.csdn.net/shengweisong/article/details/29173171

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!