码迷,mamicode.com
首页 > 其他好文 > 详细

poj Anniversary party (树形DP)

时间:2015-04-15 13:33:28      阅读:97      评论:0      收藏:0      [点我收藏+]

标签:

Anniversary party
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4825   Accepted: 2732

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests‘ ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

思路:找到根节点,开始往下搜索,从叶子节点往上递归,记录子节点信息。

对于当前节点有两个选择,选或者不选;

dp[u][0]+=max(dp[v][1],dp[v][0]);          //当前节点不选,则子节点可选可不选
dp[u][1]+=dp[v][0];                                // 选择当前节点,则子节点必不能选


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
#define N 6005
int dp[N][2];
int pre[N],vis[N];
vector<int>g[N];
void dfs(int u)
{
    int i,v;
    vis[u]=1;
    for(i=0;i<(int)g[u].size();i++)
    {
        v=g[u][i];
        if(!vis[v])
        dfs(v);
        dp[u][0]+=max(dp[v][1],dp[v][0]);
        dp[u][1]+=dp[v][0];
        //printf("%d: %d %d %d\n",u,dp[u][0],dp[v][1],dp[v][0]);
        //printf("%d %d\n",dp[u][1],dp[v][0]);
    }
}
int main()
{
    int i,n,u,v,root;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&dp[i][1]);
        dp[i][0]=0;
        pre[i]=i;
        g[i].clear();
    }
    while(scanf("%d%d",&u,&v),u||v)
    {
        pre[u]=v;
        root=v;
        g[v].push_back(u);
    }
    root=1;          //小心只有一个人的情况
    while(pre[root]!=root)  //找到根节点
        root=pre[root]; 
    memset(vis,0,sizeof(vis));   //记录访问过的节点
    dfs(root);
    printf("%d\n",max(dp[root][1],dp[root][0]));
    return 0;
}


poj Anniversary party (树形DP)

标签:

原文地址:http://blog.csdn.net/u011721440/article/details/45057547

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!