码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5202 Rikka with string (水DFS)

时间:2015-04-15 17:14:22      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:hdu   dfs   


Rikka with string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 624    Accepted Submission(s): 243

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:


One day, Yuta got a string which contains n letters but Rikka lost it in accident. Now they want to recover the string. Yuta remembers that the string only contains lowercase letters and it is not a palindrome string. Unfortunately he cannot remember some letters. Can you help him recover the string?


It is too difficult for Rikka. Can you help her?
 
Input
This problem has multi test cases (no more than 20). For each test case, The first line contains a number n(1n1000). The next line contains an n-length string which only contains lowercase letters and ‘?’ – the place which Yuta is not sure.
 
Output
For each test cases print a n-length string – the string you come up with. In the case where more than one string exists, print the lexicographically first one. In the case where no such string exists, output “QwQ”.
 
Sample Input
5 a?bb? 3 aaa
 
Sample Output
aabba QwQ
 
Source
BestCoder Round #37 ($)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5202

题目大意:问号处填字母要求字典序最小且非回文

题目分析:遇到问号搜一下,字母从a到z枚举,搜完一组判断是否是回文,不是就退出,否则回溯继续搜

#include <cstdio>
#include <cstring>
char s[1005];
int n;
bool flag;

bool ok()
{
    for(int i = 0; i < n / 2; i++)
        if(s[i] != s[n - i - 1])
            return true;
    return false;
}

void DFS(int pos)
{
    if(pos == n)
    {
        if(ok())
            flag = true;
        return;
    }
    if(s[pos] != '?')
    {  
        DFS(pos + 1);
        if(flag)
            return;
    }
    else
    {
        for(char j = 'a'; j <= 'z'; j++)
        {
            s[pos] = j;
            DFS(pos + 1);
            if(flag)
                return;
            s[pos] = '?';
        }
    }
    return;
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        flag = false;
        scanf("%s", s);
        DFS(0);
        if(flag)
            printf("%s\n", s);
        else
            printf("QwQ\n");
    }
}


 

HDU 5202 Rikka with string (水DFS)

标签:hdu   dfs   

原文地址:http://blog.csdn.net/tc_to_top/article/details/45059853

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!