码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1546

时间:2015-04-15 21:34:14      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:hdu 1546   最短路径   dijkstra算法   


Problem Description

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.
 

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
 

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
 


Sample Input

5 5 12345978ABCD2341 5 23415608ACBD3412 7 34125678AEFD4123 15 23415673ACC34123 4 41235673FBCD2156 2 20 12345678ABCD 30 DCBF5432167D 0
 

Sample Output

17 -1

#include <iostream>
#include <cstring>
#include <cstdio>
#define inf 1000000000
using namespace std;
int map[1005][1005];
char str[1005][1000];
int val[1005];
int vis[1005];
int cost[1005];
int n;
void dijkstra()
{
	memset(vis, 0, sizeof(vis));
	for (int i = 0; i<n; i++)
		cost[i] = map[0][i];
	cost[0] = 0;
	vis[0] = 1;
	for (int i = 1; i<n; i++)
	{
		int  pos,min = inf;
		for (int j = 1; j<n; j++)
			if (!vis[j] && cost[j] <= min)
			{
				pos = j;
				min = cost[j];
			}
		vis[pos] = 1;
		for (int j = 1; j<n; j++)
		{
			if (!vis[j] && (cost[j]>cost[pos] + map[pos][j]))
			{
				cost[j] = cost[pos] + map[pos][j];
			}
		}
	}
}
int main()
{
	int len;
	while (scanf("%d", &n), n)
	{
		for (int i = 0; i<n; i++)
			scanf("%d%s", &val[i], str[i]);
		for (int i = 0; i<n; i++)
		{
			len = strlen(str[i]);
			for (int j = 1; j<n; j++)
			{
				if (i == j)
					continue;
				if (str[j][0] == str[i][len - 4] && str[j][1] == str[i][len - 3] && str[j][2] == str[i][len - 2] && str[j][3] == str[i][len - 1])
					map[i][j] = val[i];
				else
				{
					map[i][j] = inf;
				}
			}
		}
		dijkstra();
		if (n == 1)
			printf("-1\n");
		else
			printf("%d\n", cost[n - 1] == inf ? -1 : cost[n - 1]);
	}
	return 0;
}


hdu 1546

标签:hdu 1546   最短路径   dijkstra算法   

原文地址:http://blog.csdn.net/u010736393/article/details/45064199

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!