码迷,mamicode.com
首页 > 其他好文 > 详细

(贪心) poj 1989

时间:2015-04-15 22:55:12      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

The Cow Lineup
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5342   Accepted: 3184

Description

Farmer John‘s N cows (1 <= N <= 100,000) are lined up in a row.Each cow is labeled with a number in the range 1...K (1 <= K <=10,000) identifying her breed. For example, a line of 14 cows might have these breeds: 
    1 5 3 2 5 1 3 4 4 2 5 1 2 3

Farmer John‘s acute mathematical mind notices all sorts of properties of number sequences like that above. For instance, he notices that the sequence 3 4 1 3 is a subsequence (not necessarily contiguous) of the sequence of breed IDs above. FJ is curious what is the length of the shortest possible sequence he can construct out of numbers in the range 1..K that is NOT a subsequence of the breed IDs of his cows. Help him solve this problem. 

Input

* Line 1: Two integers, N and K 

* Lines 2..N+1: Each line contains a single integer that is the breed ID of a cow. Line 2 describes cow 1; line 3 describes cow 2; and so on. 

Output

* Line 1: The length of the shortest sequence that is not a subsequence of the input 

Sample Input

14 5
1
5
3
2
5
1
3
4
4
2
5
1
2
3

Sample Output

3

Hint

All the single digit ‘sequences‘ appear. Each of the 25 two digit sequences also appears. Of the three digit sequences, the sequence 2, 2, 4 does not appear. 

Source

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;
int n,k;
bool vis[10010];
int main()
{
    int ans=0,cnt=0,x;
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&x);
        if(!vis[x])
        {
            vis[x]=1;
            cnt++;
        }
        if(cnt==k)
        {
            memset(vis,0,sizeof(vis));
            cnt=0;
            ans++;
        }
    }
    printf("%d\n",ans+1);
    return 0;
}

  

(贪心) poj 1989

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4430180.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!