码迷,mamicode.com
首页 > 其他好文 > 详细

[POJ 3270] Cow Sorting

时间:2015-04-16 01:06:13      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:

Cow Sorting
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6287   Accepted: 2429

Description

Farmer John‘s N (1 ≤ N ≤ 10,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage FJ‘s milking equipment, FJ would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (not necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes FJ a total of X+Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help FJ calculate the minimal time required to reorder the cows.

Input

Line 1: A single integer: N.  Lines 2..N+1: Each line contains a single integer: line i+1 describes the grumpiness of cow i. 

Output

Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.

Sample Input

3
2
3
1

Sample Output

7

Hint

2 3 1 : Initial order.  2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4).  1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

Source

 
置换群、代码比较丑
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
#define INF 0x3f3f3f3f
#define N 10010

int n;
int mi;
int b[N];
int vis[N];

struct Node
{
    int ori,now;
}a[N];

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        mi=INF;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i].ori);
            mi=min(a[i].ori,mi);
            b[i]=a[i].ori;
        }
        sort(b+1,b+n+1);
        for(int i=1;i<=n;i++)
        {
            a[i].now=lower_bound(b+1,b+n+1,a[i].ori)-b;
        }
        int ans=0;
        int len,sum,t1,t2;
        for(int i=1;i<=n;i++)
        {
            if(a[i].now!=i)
            {
                len=1;
                sum=0;
                while(a[i].now!=i)
                {
                    len++;
                    sum+=a[i].ori;
                    swap(a[i],a[a[i].now]);
                }
                t1=sum+(len-1)*a[i].ori;
                t2=sum+(len-1)*mi+(a[i].ori+mi)*2;
                ans+=min(t1,t2);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

[POJ 3270] Cow Sorting

标签:

原文地址:http://www.cnblogs.com/hate13/p/4430655.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!