码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5194 DZY Loves Balls(概率)

时间:2015-04-16 09:09:31      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:acm   概率 hdu   

Problem Description:

There are n black balls and m white balls in the big box.

Now, DZY starts to randomly pick out the balls one by one. It forms a sequence S. If at the i-th operation, DZY takes out the black ball, Si=1, otherwise Si=0.

DZY wants to know the expected times that ‘01‘ occurs in S.

Input:

The input consists several test cases. (TestCase150)

The first line contains two integers, n, m(1n,m12)

Output:

For each case, output the corresponding result, the format is p/q(p and q are coprime)

Sample Input:

1 1
2 3

Sample Output:

1/2
6/5

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
const int MAXN = 1000 + 10;
int n, m;
int gcd(int a, int b)
{
    return b == 0 ? a : gcd(b, a % b);
}
int main()
{
	while(scanf("%d%d", &n, &m)!=EOF)
	{
	    int c = gcd(n*m, n + m);
		printf("%d/%d\n", n*m/c, (n+m)/c);
	}
	return 0;
}



HDU 5194 DZY Loves Balls(概率)

标签:acm   概率 hdu   

原文地址:http://blog.csdn.net/moguxiaozhe/article/details/45066659

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!