码迷,mamicode.com
首页 > 其他好文 > 详细

[HiHoCoder]#1051 : 补提交卡

时间:2015-04-16 19:59:26      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:hihocoder   java   

#1051 : 补提交卡

时间限制:2000ms
单点时限:1000ms
内存限制:256MB

描述

小Ho给自己定了一个宏伟的目标:连续100天每天坚持在hihoCoder上提交一个程序。100天过去了,小Ho查看自己的提交记录发现有N天因为贪玩忘记提交了。于是小Ho软磨硬泡、强忍着小Hi鄙视的眼神从小Hi那里要来M张"补提交卡"。每张"补提交卡"都可以补回一天的提交,将原本没有提交程序的一天变成有提交程序的一天。小Ho想知道通过利用这M张补提交卡,可以使自己的"最长连续提交天数"最多变成多少天。

输入

第一行是一个整数T(1 <= T <= 10),代表测试数据的组数。

每个测试数据第一行是2个整数N和M(0 <= N, M <= 100)。第二行包含N个整数a1, a2, ... aN(1 <= a1 < a2 < ... < aN <= 100),表示第a1, a2, ...  aN天小Ho没有提交程序。

输出

对于每组数据,输出通过使用补提交卡小Ho的最长连续提交天数最多变成多少。

样例输入
3  
5 1  
34 77 82 83 84  
5 2  
10 30 55 56 90  
5 10  
10 30 55 56 90
样例输出
76  
59
100



import java.util.Scanner;

public class Main {
  
  
  private static int maxLen(int arr[],int m,int n){
    if(m>=n) return 100;
    int res = arr[m]-1;
    for(int i=0;i+m+1<n;i++){
      res = Math.max(res, arr[i+m+1]-arr[i]-1);
    }
    res = Math.max(res, 100-arr[n-m-1]);
    return res;
  }
  
  public static void main(String args[]){
    Scanner sc = new Scanner(System.in);
/*    Scanner sc = null;
    try {
      sc = new Scanner(new FileInputStream("C:\\Users\\ddguo\\Desktop\\input.txt"));
    } catch (FileNotFoundException e) {
      // TODO Auto-generated catch block
      e.printStackTrace();
    }*/
    
    int num = sc.nextInt();
    while(num-->0){
      int n = sc.nextInt();
      int m = sc.nextInt();
      int arr[] = new int[n];
      for(int i=0;i<n;i++){
        arr[i]= sc.nextInt();
      }
      System.out.println(maxLen(arr, m, n));
    }
    sc.close();
  }
}


[HiHoCoder]#1051 : 补提交卡

标签:hihocoder   java   

原文地址:http://blog.csdn.net/guorudi/article/details/45078547

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!