码迷,mamicode.com
首页 > 其他好文 > 详细

(0染色判定二分图) hdu 4751

时间:2015-04-16 21:34:23      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:

J - Divide Groups
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

技术分享

  This year is the 60th anniversary of NJUST, and to make the celebration more colorful, Tom200 is going to invite distinguished alumnus back to visit and take photos. 
  After carefully planning, Tom200 announced his activity plan, one that contains two characters: 
  1. Whether the effect of the event are good or bad has nothing to do with the number of people join in. 
   2. The more people joining in one activity know each other, the more interesting the activity will be. Therefore, the best state is that, everyone knows each other.
  The event appeals to a great number of alumnus, and Tom200 finds that they may not know each other or may just unilaterally recognize others. To improve the activities effects, Tom200 has to divide all those who signed up into groups to take part in the activity at different time. As we know, one‘s energy is limited, and Tom200 can hold activity twice. Tom200 already knows the relationship of each two person, but he cannot divide them because the number is too large. 
  Now Tom200 turns to you for help. Given the information, can you tell if it is possible to complete the dividing mission to make the two activity in best state.
 

Input

  The input contains several test cases, terminated by EOF. 
  Each case starts with a positive integer n (2<=n<=100), which means the number of people joining in the event. 
  N lines follow. The i-th line contains some integers which are the id 
of students that the i-th student knows, terminated by 0. And the id starts from 1.
 

Output

  If divided successfully, please output "YES" in a line, else output "NO". 
 

Sample Input

3 3 0 1 0 1 2 0
 

Sample Output

YES
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<map>
using namespace std;
vector<int> e[105];
int n;
int mp[105][105],mark[105];
bool dfs(int x,int colour)
{
    mark[x]=colour;
    for(int i=0;i<e[x].size();i++)
    {
        if(mark[e[x][i]]!=-1)
        {
            if(mark[e[x][i]]==colour)
            {
                return false;
            }
        }
        else
        {
            if(!dfs(e[x][i],!colour))
                return false;
        }
    }
    return true;
}
int main()
{
    int x;
    while(scanf("%d",&n)!=EOF)
    {
        memset(mp,0,sizeof(mp));
        for(int i=1;i<=n;i++)
        {
            e[i].clear();
            while(scanf("%d",&x)!=EOF)
            {
                if(x==0)
                    break;
                mp[i][x]=1;
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                if(mp[i][j]==0||mp[j][i]==0)
                {
                    e[i].push_back(j);
                    e[j].push_back(i);
                }
            }
        }
        bool flag=true;
        memset(mark,-1,sizeof(mark));
        for(int i=1;i<=n;i++)
        {
            if(mark[i]==-1&&!dfs(i,0))
            {
                flag=false;
                break;
            }
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

  

(0染色判定二分图) hdu 4751

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4433089.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!