码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目4372 Count the Buildings(斯特林第一类数)

时间:2015-04-16 21:59:00      阅读:220      评论:0      收藏:0      [点我收藏+]

标签:

Count the Buildings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 738    Accepted Submission(s): 246


Problem Description
There are N buildings standing in a straight line in the City, numbered from 1 to N. The heights of all the buildings are distinct and between 1 and N. You can see F buildings when you standing in front of the first building and looking forward, and B buildings when you are behind the last building and looking backward. A building can be seen if the building is higher than any building between you and it.
Now, given N, F, B, your task is to figure out how many ways all the buildings can be.
 

Input
First line of the input is a single integer T (T<=100000), indicating there are T test cases followed.
Next T lines, each line consists of three integer N, F, B, (0<N, F, B<=2000) described above.
 

Output
For each case, you should output the number of ways mod 1000000007(1e9+7).
 

Sample Input
2 3 2 2 3 2 1
 

Sample Output
2 1
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:  4059 1098 1130 1131 1134 
ac代码
#include<stdio.h>
#include<string.h>
#define mod 1000000007
__int64 s[2010][2010],c[2010][2010],n,f,b;
void fun()
{
    int i,j;
    for(i=0;i<2010;i++)
    {
        c[i][0]=1;
        c[i][i]=1;
        s[i][0]=0;
        s[i][i]=1;
        for(j=0;j<i;j++)
        {
            c[i][j]=(c[i-1][j-1]+c[i-1][j])%mod;
            s[i][j]=(s[i-1][j]*(i-1)%mod+s[i-1][j-1])%mod;
        }
    }
}
int main()
{
    int t;
    fun();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d",&n,&f,&b);
        printf("%I64d\n",c[b+f-2][f-1]*s[n-1][f+b-2]%mod);
    }
}

 

HDOJ 题目4372 Count the Buildings(斯特林第一类数)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/45080189

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!