码迷,mamicode.com
首页 > 其他好文 > 详细

(状态压缩DP) zoj 3471

时间:2015-04-16 23:40:24      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:

T - Most Powerful
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

 

Input

 

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

 

Output

 

Output the maximal power these N atoms can produce in a line for each case.

 

Sample Input

 

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

 

Sample Output

 

4
22

 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
int n,mp[15][15];
int dp[(1<<10)+5];
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
                scanf("%d",&mp[i][j]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=(1<<n)-1;i>=0;i--)
        {
            for(int j=0;j<n;j++)
            {
                if(i&(1<<j))
                {
                    for(int k=0;k<n;k++)
                    {
                        if(j==k)
                            continue;
                        if(i&(1<<k)) continue;
                        dp[i]=max(dp[i],dp[i|(1<<k)]+mp[j][k]);
                    }
                }
            }
        }
        int ans=0;
        for(int i=0;i<n;i++)
            ans=max(ans,dp[1<<i]);
        printf("%d\n",ans);
    }
    return 0;
}

  

(状态压缩DP) zoj 3471

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4433533.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!