码迷,mamicode.com
首页 > 其他好文 > 详细

FZU 2148 Moon Game 判断凸边形

时间:2015-04-17 23:55:58      阅读:296      评论:0      收藏:0      [点我收藏+]

标签:


Problem 2148 Moon Game

Accept: 512    Submit: 1419
Time Limit: 1000 mSec    Memory Limit : 32768 KB

技术分享 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game in the clearly blue sky which we can just consider as a kind of two-dimensional plane. Then Fat brother starts to draw N starts in the sky which we can just consider each as a point. After he draws these stars, he starts to sing the famous song “The Moon Represents My Heart” to Maze.

You ask me how deeply I love you,

How much I love you?

My heart is true,

My love is true,

The moon represents my heart.

But as Fat brother is a little bit stay-adorable(呆萌), he just consider that the moon is a special kind of convex quadrilateral and starts to count the number of different convex quadrilateral in the sky. As this number is quiet large, he asks for your help.

技术分享 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains an integer N describe the number of the points.

Then N lines follow, Each line contains two integers describe the coordinate of the point, you can assume that no two points lie in a same coordinate and no three points lie in a same line. The coordinate of the point is in the range[-10086,10086].

1 <= T <=100, 1 <= N <= 30

技术分享 Output

For each case, output the case number first, and then output the number of different convex quadrilateral in the sky. Two convex quadrilaterals are considered different if they lie in the different position in the sky.

技术分享 Sample Input

240 0100 00 100100 10040 0100 00 10010 10

技术分享 Sample Output

Case 1: 1Case 2: 0

n个点,判断能形成多少个凸多边形。
直接暴力所有的点,凸多边形不好判断,可以判断凹多边形,如果存在一点d:Sabc=Sabd+Sacd+Sbcd,则为凸边形。
//140 ms	216KB
#include<stdio.h>
#include<math.h>
#define eps 1e-9
struct P
{
    int x,y;
}p[1007];
double area(P a, P b, P c)
{
     return a.x * b.y + c.x * a.y + b.x * c.y - c.x * b.y - a.x * c.y - b.x * a.y;
}
bool ok(P a,P b,P c,P d)
{
    double sum1 = fabs(area(a, b, d)) + fabs(area(a, c, d)) + fabs(area(b, c, d));
    double sum2 = fabs(area(a, b, c));
    if(sum1==sum2)return true;
    return false;
}
bool judge(P a,P b,P c,P d)
{
    if(ok(a,b,c,d))return false;
    if(ok(a,b,d,c))return false;
    if(ok(a,c,d,b))return false;
    if(ok(b,c,d,a))return false;
    return true;
}
int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,ans=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d%d",&p[i].x,&p[i].y);
        for(int i=0;i<n;i++)
            for(int j=i+1;j<n;j++)
                for(int x=j+1;x<n;x++)
                    for(int y=x+1;y<n;y++)
                        if(judge(p[i],p[j],p[x],p[y]))
                            ans++;
        printf("Case %d: %d\n",cas++,ans);
    }
    return 0;
}


FZU 2148 Moon Game 判断凸边形

标签:

原文地址:http://blog.csdn.net/crescent__moon/article/details/45103221

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!