码迷,mamicode.com
首页 > 其他好文 > 详细

hud 2923 最短路(Floyd)

时间:2015-04-18 14:34:20      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:floyd算法   最短路径   acm   

Problem Description

Einbahnstra 技术分享 e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company‘s garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company‘s garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company‘s garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.
 

Input

Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company‘s garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company‘s garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:


A -v -> B
A <-v - B
A <-v -> B


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.

技术分享
 

Output

For each test case, print the total distance traveled using the following format:


k . V


Where k is test case number (starting at 1,) is a space, and V is the result.
 

Sample Input

4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0
 

Sample Output

1. 8


#include <iostream>
#include <stdio.h>
#include <cstring>
#include <map>
#include <algorithm>
using namespace std;
#define inf 1000000000
const int L = 1005;
int n, c, m;
int a[105][105];
char location[1005][100];
char s1[100], s2[100];
char from, to;
int cnt;
map<string, int> mat;


void Floyd()
{
	int i, j, k;
	for (i = 1; i <= n; i++)
		for (j = 1; j <= n; j++)
			for (k = 1; k <= n; k++)
				if (a[j][i] + a[i][k]<a[j][k])
					a[j][k] = a[j][i] + a[i][k];
}

int main()
{
	int val, x, y, len, cas = 1, sum, start,end;
	while (~scanf("%d%d%d", &n, &c, &m) && (n + c + m))
	{
		sum = 0;
		mat.clear();
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)
				a[i][j] = inf;
		for (int i = 0; i <= c; i++)
			scanf("%s", location[i]);
		cnt = 1;
		for (int i = 0; i<m; i++)
		{
			scanf("%s %c-%d-%c %s", s1, &from, &val, &to, s2);
			if (!mat[s1])
				mat[s1] = cnt++;
			if (!mat[s2])
				mat[s2] = cnt++;
			x = mat[s1], y = mat[s2];
			if (from == '<' && val<a[y][x])
				a[y][x] = val;
			if (to == '>' && val<a[x][y])
				a[x][y] = val;
		}
		Floyd();
		start = mat[location[0]];
		for (int i = 1; i <= c; i++)
			end = mat[location[i]];
			sum += a[start][end] + a[end][start];
		printf("%d. %d\n", cas++, sum);
	}

	return 0;
}


hud 2923 最短路(Floyd)

标签:floyd算法   最短路径   acm   

原文地址:http://blog.csdn.net/u010736393/article/details/45102989

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!