码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1688 Sightseeing(SPFA 求最短路与次短路的路径条数)可用作模板

时间:2015-04-18 23:48:52      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:spfa   图论   

Sightseeing

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 718    Accepted Submission(s): 293


Problem Description
Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

技术分享

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

M lines, each with three integers A, B and L, separated by single spaces, with 1 ≤ A, B ≤ N, A ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.

The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

One line with two integers S and F, separated by a single space, with 1 ≤ S, F ≤ N and S ≠ F: the starting city and the final city of the route.

There will be at least one route from S to F.

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 10^9 = 1,000,000,000.

 

Sample Input
2 5 8 1 2 3 1 3 2 1 4 5 2 3 1 2 5 3 3 4 2 3 5 4 4 5 3 1 5 5 6 2 3 1 3 2 1 3 1 10 4 5 2 5 2 7 5 2 7 4 1
 

Sample Output
3 2
 

Source
题意:给出一个有向图,两个点之间可有多条同向同值的直接路。问从S 点 到 F点   的 最短路条数与 最短路距离+1 路径条数    总和是多少。
#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
const int N = 1005;
const int inf = 1e9;
struct EDG
{
    int v,d;
};
struct node
{
    int v,c;
};

vector<EDG>mapt[N];
int spfa(int sp,int ep,int n)
{
    int inq[N][2]={0},dis[N][3],num[N][2];
    queue<node>q; //队列里面的节点都是需要更新的
    node pre,now;

    for(int i=1;i<=n;i++)
    {
        dis[i][0]=dis[i][1]=inf;
        dis[i][2]=inf; //只是用于标记当前(i,0)组合点己更新过的值
        num[i][0]=num[i][1]=0;
    }
    now.v=sp; now.c=0; dis[sp][0]=0; num[sp][0]=1; q.push(now);

    while(!q.empty())
    {
        pre=q.front(); q.pop();
        inq[pre.v][pre.c]=0;

        if(pre.c==0) //为下次被替换到次小值时,是否需要再一次根据当前值更新作判断依居
        dis[pre.v][2]=dis[pre.v][0];

        int k=mapt[pre.v].size();
        for(int i=0;i<k;i++)
        {
            now.v=mapt[pre.v][i].v;

            if(dis[now.v][0]>=dis[pre.v][pre.c]+mapt[pre.v][i].d)
            {
                if(dis[now.v][0]>dis[pre.v][pre.c]+mapt[pre.v][i].d)
                {
                    dis[now.v][1]=dis[now.v][0];
                    num[now.v][1]=num[now.v][0];
                    //当最小被替换成次小时,如果这个值没有更新过,就一定要放入队列
                    now.c=1;
                    if(inq[now.v][now.c]==0&&dis[now.v][now.c]!=dis[now.v][2])
                     q.push(now),inq[now.v][now.c]=1;

                    dis[now.v][0]=dis[pre.v][pre.c]+mapt[pre.v][i].d;
                    num[now.v][0]=num[pre.v][pre.c];
                }
                else num[now.v][0]+=num[pre.v][pre.c];

                now.c=0;
                if(inq[now.v][now.c]==0)
                q.push(now),inq[now.v][now.c]=1;
            }
            else if(dis[now.v][1]>=dis[pre.v][pre.c]+mapt[pre.v][i].d)
            {
                if(dis[now.v][1]>dis[pre.v][pre.c]+mapt[pre.v][i].d)
                {
                    dis[now.v][1]=dis[pre.v][pre.c]+mapt[pre.v][i].d;
                    num[now.v][1]=num[pre.v][pre.c];
                }
                else num[now.v][1]+=num[pre.v][pre.c];
                now.c=1;
                if(inq[now.v][now.c]==0)
                q.push(now),inq[now.v][now.c]=1;
            }
        }
    }
    
    if(dis[ep][1]==dis[ep][0]+1)
        num[ep][0]+=num[ep][1];
    return num[ep][0];
}
int main()
{
    int t,n,m,a;
    EDG ss;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            mapt[i].clear();
        while(m--)
        {
            scanf("%d%d%d",&a,&ss.v,&ss.d);
            mapt[a].push_back(ss);
        }
        int sp,ep;
        scanf("%d%d",&sp,&ep);

        printf("%d\n",spfa(sp,ep,n));
    }
}

 

HDU1688 Sightseeing(SPFA 求最短路与次短路的路径条数)可用作模板

标签:spfa   图论   

原文地址:http://blog.csdn.net/u010372095/article/details/45118813

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!