码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3471 Most Powerful(状压DP)

时间:2015-04-19 06:33:12      阅读:115      评论:0      收藏:0      [点我收藏+]

标签:

Description

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22

简单的状压DP。dp[i]代表二进制下第i的原子核是否还在(1)

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int INF = 0x3f3f3f3f;
int dp[(1<<10)+100];
int mp[15][15];
int n;

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        REPF(i,1,n)
          REPF(j,1,n)  scanf("%d",&mp[i][j]);
        CLEAR(dp,0);int ans=0;
        int status=(1<<n)-1;
        for(int i=status;i>=0;i--)
        {
            for(int j=1;j<=n;j++)
            {
                if((i&(1<<(j-1)))==0) continue;
                for(int k=1;k<=n;k++)
                {
                    if(k==j||(i&(1<<(k-1)))==0) continue;
                    int st=i^(1<<(k-1));
                    dp[st]=max(dp[st],dp[i]+mp[j][k]);
                    if(dp[st]>ans) ans=dp[st];
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

/*

*/


ZOJ 3471 Most Powerful(状压DP)

标签:

原文地址:http://blog.csdn.net/u013582254/article/details/45122675

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!