码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3600 Taxi Fare(数学啊)

时间:2015-04-19 21:25:23      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:zoj   数学   

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4703



Last September, Hangzhou raised the taxi fares.

The original flag-down fare in Hangzhou was 10 yuan, plusing 2 yuan per kilometer after the first 3km and 3 yuan per kilometer after 10km. The waiting fee was 2 yuan per five minutes. Passengers need to pay extra 1 yuan as the fuel surcharge.

According to new prices, the flag-down fare is 11 yuan, while passengers pay 2.5 yuan per kilometer after the first 3 kilometers, and 3.75 yuan per kilometer after 10km. The waiting fee is 2.5 yuan per four minutes.

The actual fare is rounded to the nearest yuan, and halfway cases are rounded up. How much more money does it cost to take a taxi if the distance is d kilometers and the waiting time is t minutes.

Input

There are multiple test cases. The first line of input is an integer T ≈ 10000 indicating the number of test cases.

Each test case contains two integers 1 ≤ d ≤ 1000 and 0 ≤ t ≤ 300.

Output

For each test case, output the answer as an integer.

Sample Input

4
2 0
5 2
7 3
11 4

Sample Output

0
1
3
5

Author: WU, Zejun
Contest: The 9th Zhejiang Provincial Collegiate Programming Contest


PS:

注意结果要四舍五入, 加个0.5 在强制转换就好了!

代码如下:

#include<cstdio>
#include<cmath>
#include<iostream>
using namespace std;
int main()
{
	int T,d,t,a,b;
	double sum1,sum2;
	while(cin >> T)
	{
		while(T--)
		{
			cin >> d >> t;
			sum1=11;
			sum2=11;
			if(d>3&&d<=10)
			{
				sum1+=(d-3)*2;
				sum2+=(d-3)*2.5;
			}
			else if(d>10)
			{
				sum1+=7*2+(d-10)*3;
				sum2+=7*2.5+(d-10)*3.75;
			}
			sum1+=(t/5.0)*2;
			sum2+=(t/4.0)*2.5;
			a=(int)(sum1+0.5);
			b=(int)(sum2+0.5);
			if(a>b)
				cout << a - b << endl;
			else
				cout << b - a << endl;
		}
	}
	return 0;
}


ZOJ 3600 Taxi Fare(数学啊)

标签:zoj   数学   

原文地址:http://blog.csdn.net/u012860063/article/details/45132481

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!