码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1090. Highest Price in Supply Chain (25)(DFS啊 )

时间:2015-04-19 21:26:15      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:pat   dfs   

题目链接:http://www.patest.cn/contests/pat-a-practise/1090


A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2
题意:

给出初始价格和增长率!

求最高价格,和不同的路径数!

代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
vector<int >a[100017];
int maxdep;
int cont;
int n;
void dfs(int tem, int dep)
{
	if(a[tem].size() == 0)//走到底,不能再供应给其他人
	{
		if(dep > maxdep)
		{
			cont = 1;
			maxdep = dep;
		}
		else if(dep == maxdep)
		{
			cont++;
		}
	}
	for(int i = 0; i < a[tem].size(); i++)
	{
		dfs(a[tem][i], dep+1);
	}
}

int main()
{
	double p, r;
	while(~scanf("%d%lf%lf",&n,&p,&r))
	{
		cont = 0;
		maxdep = 0;
		int t, i;
		int root;
		for(i = 0; i < n; i++)
		{
			scanf("%d",&t);
			if(t == -1)
			{
				root = i;
				continue;
			}
			a[t].push_back(i);
		}
		dfs(root, 0);
		double ans = p;
		for(i = 0; i < maxdep; i++)
		{
			ans = ans*(100+r)/100.0;
		}
		printf("%.2lf %d\n",ans,cont);
	}
	return 0;
}


PAT 1090. Highest Price in Supply Chain (25)(DFS啊 )

标签:pat   dfs   

原文地址:http://blog.csdn.net/u012860063/article/details/45132161

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!