码迷,mamicode.com
首页 > 其他好文 > 详细

容斥原理

时间:2015-04-20 11:11:45      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5008    Accepted Submission(s): 1421


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

 

Output
  For each case, output the number.
 

 

Sample Input
12 2 2 3
 

 

Sample Output
7
 

 

Author
wangye
 

 

Source
 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;
LL n,m,num[15],ans;
LL gcd(LL a,LL b)
{
    return b>0?gcd(b,a%b):a;
}
void dfs(int id,int flag,LL LCM)
{
    LCM=num[id]/gcd(num[id],LCM)*LCM;
    if(flag)
        ans+=n/LCM;
    else
        ans-=n/LCM;
    for(int i=id+1;i<=m;i++)
        dfs(i,!flag,LCM);
}
int main()
{
    while(scanf("%I64d%I64d",&n,&m)!=EOF)
    {
        n--;
        ans=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%I64d",&num[i]);
            if(num[i]==0)
                i--,m--;
        }
        sort(num+1,num+1+m);
        for(int i=1;i<=m;i++)
            dfs(i,1,num[i]);
        printf("%I64d\n",ans);
    }
    return 0;
}

  

容斥原理

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4440749.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!