码迷,mamicode.com
首页 > 其他好文 > 详细

杭电1093(不会做)

时间:2015-04-20 20:46:06      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

问题描述

你的任务是计算一些整数的总和。

 

 

输入

输入的第一行包含一个整数N,N,然后行。每一行始于一个整数,然后米整数遵循相同的路线。

输出

每组输入整数,你应该输出一行的总和,和一行输出输入的每一行。

样例输入

2

4 1 2 3 4

5 1 2 3 4 5

样例输出

10

15

#include<stdio.h>
int main()
{
    int a,n,sum,i;
    scanf("%d",&i);
    while(i--)
    {
          scanf("%d",&n);
             sum=0;
        
             while(n--)
             {
                scanf("%d",&a);
                sum+=a;
             }
           printf("%d\n",sum);
    }
    return 0;
}

这种方法更容易理解.

while(n--):

while表达式,n--为判断语句,如果n自减到0是,就跳出while循环,如果没有继续执行while下面的语句,while跟for语句差不多,for(int n=3;n>0;n--)跟int n=3;while(n--){n>0}一样
以后要多看看这题直到自己能敲出来为止

杭电1093(不会做)

标签:

原文地址:http://www.cnblogs.com/woderenshengluwozijizou/p/4442463.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!