码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2010省赛集训队选拔赛(校内赛) H

时间:2015-04-21 09:48:17      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:递归

#define is unsafe

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 287    Accepted Submission(s): 178



Problem Description
Have you used #define in C/C++ code like the code below?

#include <stdio.h>
#define MAX(a , b) ((a) > (b) ? (a) : (b))
int main()
{
  printf("%d\n" , MAX(2 + 3 , 4));
  return 0;
}

Run the code and get an output: 5, right?
You may think it is equal to this code:

#include <stdio.h>
int max(a , b) {  return ((a) > (b) ? (a) : (b));  }
int main()
{
  printf("%d\n" , max(2 + 3 , 4));
  return 0;
}

But they aren‘t.Though they do produce the same anwser , they work in two different ways.
The first code, just replace the MAX(2 + 3 , 4) with ((2 + 3) > (4) ? (2 + 3) : 4), which calculates (2 + 3) twice.
While the second calculates (2 + 3) first, and send the value (5 , 4) to function max(a , b) , which calculates (2 + 3) only once.

What about MAX( MAX(1+2,2) , 3 ) ?
Remember "replace".
First replace: MAX( (1 + 2) > 2 ? (1 + 2) : 2 , 3)
Second replace: ( ( ( 1 + 2 ) > 2 ? ( 1 + 2 ) : 2 ) > 3 ? ( ( 1 + 2 ) > 2 ? ( 1 + 2 ) : 2 ) : 3).
The code may calculate the same expression many times like ( 1 + 2 ) above.
So #define isn‘t good.In this problem,I‘ll give you some strings, tell me the result and how many additions(加法) are computed.
 

Input
The first line is an integer T(T<=40) indicating case number.
The next T lines each has a string(no longer than 1000), with MAX(a,b), digits, ‘+‘ only(Yes, there‘re no other characters).
In MAX(a,b), a and b may be a string with MAX(c,d), digits, ‘+‘.See the sample and things will be clearer.
 

Output
For each case, output two integers in a line separated by a single space.Integers in output won‘t exceed 1000000.
 

Sample Input
6 MAX(1,0) 1+MAX(1,0) MAX(2+1,3) MAX(4,2+2) MAX(1+1,2)+MAX(2,3) MAX(MAX(1+2,3),MAX(4+5+6,MAX(7+8,9)))+MAX(10,MAX(MAX(11,12),13))
 

Sample Output
1 0 2 1 3 1 4 2 5 2 28 14
 

Author
madfrog
 

Source
HDU2010省赛集训队选拔赛(校内赛)

题意: 看吧!
题解: 一个简单的模拟题,用递归写超简单啊啊啊啊啊啊啊!!!!!!

AC代码:
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <cmath>

using namespace std;
const int MAXN = 1e3 + 100;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int>P;
char s[MAXN];

int my_find(int l,int r)
{
    int cnt = 0;
    for(int i = l; i < r; i++)
    {
        if(s[i] == '(') cnt++;
        else if(s[i] == ')') cnt--;
        else if(s[i] == '+' && !cnt) return i;
    }
    return -1;
}

int my1_find(int l,int r)
{
    int cnt = 0;
    for(int i = l; i < r; i++)
    {
        if(s[i] == '(') cnt++;
        else if(s[i] == ')') cnt--;
        else if(s[i] == ',' && !cnt) return i;
    }
}

P solve(int l,int r)
{
    int v = my_find(l,r);
    if(v != -1)
    {
        P a = solve(l,v);
        P b = solve(v + 1,r);
        P c = make_pair(a.first + b.first,a.second + b.second + 1);
        return c;
    }
    if(s[l] == 'M')
    {
        int pos = my1_find(l + 4,r);
        P a = solve(l + 4,pos);
        P b = solve(pos + 1,r - 1);
        if(a.first > b.first)
            return make_pair(a.first,a.second * 2 + b.second);
        else return make_pair(b.first,b.second * 2 + a.second);
    }
    int cnt,res;
    res = cnt = 0;
    for(int i = l,t = 0; i <= r; i++)
    {
        if(isdigit(s[i])) t = t * 10 + s[i] - '0';
        else
        {
            if(i < r) cnt++;
            res += t;
            t = 0;
        }
    }
    return make_pair(res,cnt);
}

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        scanf("%s",s);
        int len = strlen(s);
        P ans = solve(0,len);
        printf("%d %d\n",ans.first,ans.second);
    }
    return 0;
}


 

HDU2010省赛集训队选拔赛(校内赛) H

标签:递归

原文地址:http://blog.csdn.net/zsgg_acm/article/details/45156247

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!