标签:acm算法 algorithm amp iostream namespace
Genealogical tree
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 3314 |
|
Accepted: 2226 |
|
Special Judge |
Description
The system of Martians‘ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will
be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than
to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there‘s nothing to tell about his grandparents!). But if by a mistake
first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input
The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural
numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member‘s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may
be empty. The list (even if it is empty) ends with 0.
Output
The standard output should contain in its only line a sequence of speakers‘ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least
one such sequence always exists.
Sample Input
5
0
4 5 1 0
1 0
5 3 0
3 0
Sample Output
2 4 5 3 1
Source
拓扑排序入门题。。。
就是让所有的v不得出现在u之前。
适用于无环有向图
#include <set>
#include <cstdio>
#include <queue>
#include <map>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
const double PI=acos(-1.0);
using namespace std;
int n,len;
int edge[110][110];
int cnt[110];
int vis[110];
void t_p_sort()
{
priority_queue<int>q;
int i,j;
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
if(edge[i][j])
cnt[j]++; //入度加一。
for(i=1; i<=n; i++)
{
if(cnt[i]==0) // 找一个起点
q.push(i);
}
int temp;
while(!q.empty())
{
temp=q.top();
q.pop();
vis[len++]=temp;
for(i=1; i<=n; i++)
{
if(edge[temp][i])
{
cnt[i]--; //找到u->v v的入度减一
if(cnt[i]==0) //如果v变成起点,继续循环。
q.push(i);
}
}
}
return;
}
int main()
{
int u,v,i;
while(cin>>n)
{
int p=n;
memset(edge,0,sizeof(edge));
memset(cnt,0,sizeof(cnt));
memset(vis,0,sizeof(vis));
len=0;
u=1;
while(p--)
{
while(cin>>v,v)
edge[u][v]=1;
u++;
}
t_p_sort();
for(i=0; i<len; i++)
{
if(!i)
cout<<vis[i];
else
cout<<" "<<vis[i];
}
cout<<endl;
}
return 0;
}
POJ 2367 Genealogical tree
标签:acm算法 algorithm amp iostream namespace
原文地址:http://blog.csdn.net/sky_miange/article/details/45171479