码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2184---Cow Exhibition(01背包变形)

时间:2015-04-21 22:51:44      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:dp

Description
“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input
* Line 1: A single integer N, the number of cows

  • Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

Source
USACO 2003 Fall

直接当01背包来搞,注意体积可能为负

/*************************************************************************
    > File Name: POJ2184.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年04月21日 星期二 18时12分07秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

static const int N = 100100;
int dp[N << 2];
int a[110], b[110];

int main() {
    int n;
    while (~scanf("%d", &n)) {
        memset(dp, -inf, sizeof(dp));
        dp[100000] = 0;
        for (int i = 1; i <= n; ++i) {
            scanf("%d%d", &a[i], &b[i]);
        }
        for (int i = 1; i <= n; ++i) {
            if (a[i] >= 0) {
                for (int j = 200000; j >= a[i]; --j) {
                    if (dp[j - a[i]] != -inf) {
                        dp[j] = max(dp[j], dp[j - a[i]] + b[i]);
                    }
                }
            }
            else {
                for (int j = 0; j <= 200000; ++j) {
                    if (dp[j - a[i]] != -inf) {
                        dp[j] = max(dp[j], dp[j - a[i]] + b[i]);
                    }
                }
            }
        }
        int ans = 0;
        for (int j = 100001; j <= 200000; ++j) {
            if (dp[j] != -inf && dp[j] > 0) {
                ans = max(ans, j + dp[j] - 100000);
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

POJ2184---Cow Exhibition(01背包变形)

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/45174097

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!