码迷,mamicode.com
首页 > 其他好文 > 详细

(并查集) poj 2492

时间:2015-04-22 00:22:48      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:

A Bug‘s Life
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 29940   Accepted: 9802

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
int n,m;
int fa[1000005],a[1000005];
int find(int x)
{
    if(x!=fa[x])
        fa[x]=find(fa[x]);
    return fa[x];
}
void Union(int x,int y)
{
    int fx,fy;
    fx=find(x),fy=find(y);
    if(fx!=fy)
        fa[fx]=fy;
}
int main()
{
    int tt,x,y,cas=1;
    scanf("%d",&tt);
    while(tt--)
    {
        bool flag=true;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            fa[i]=i,a[i]=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            int fx,fy;
            fx=find(x),fy=find(y);
            if(fx==fy)
            {
                flag=false;
            }
            if(!a[x])
                a[x]=y;
            else
            {
                Union(a[x],y);
            }
            if(!a[y])
            {
                a[y]=x;
            }
            else
            {
                Union(a[y],x);
            }
        }
        printf("Scenario #%d:\n",cas++);
        if(!flag)
            printf("Suspicious bugs found!\n\n");
        else
            printf("No suspicious bugs found!\n\n");
    }
    return 0;
}

  

(并查集) poj 2492

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4445999.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!