码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3333 Guess the price

时间:2015-04-22 09:37:38      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:最水题   入门   zoj   

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3758


题面:


Guess the Price

Time Limit: 1 Second      Memory Limit: 32768 KB

In the television program "Shopping Street" of CCTV-2, two people, A and B are guessing price of a given item. You are asked to decide whose price is closer to the real price.

Input

There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.

Each case contains three integers in one line: PPAPB (0 <= PAPB <= P <= 100, PA != PB), indicating the real price, the price A guesses and the price B guesses.

Output

For each case, output "A" or "B" according to whose price is closer to the real price.

Sample Input

3
10 8 7
20 20 19
100 9 50

Sample Output

A
A
B

题意:求两个价格哪个与实际价格更接近。

其实,题目有点纰漏,只说pa!=pb,但差值还是可能相等,不过测试样例里没有。


代码:

#include<iostream>
#include <cmath>
using namespace std;
int main()
{
	int t,p1,p2,p;
    cin>>t;
    while(t--)
    {
    	cin>>p>>p1>>p2;
    	if(abs(p-p1)<abs(p-p2))cout<<"A\n";
    	else cout<<"B\n";
    }
	return 0;
} 


ZOJ 3333 Guess the price

标签:最水题   入门   zoj   

原文地址:http://blog.csdn.net/david_jett/article/details/45179757

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!