码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3640 Help Me Escape(概率dp+记忆化)

时间:2015-04-22 09:41:23      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:概率dp

Background

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him.
    And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him.
    And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother‘s keeper?
    And he said, What hast thou done? the voice of thy brother‘s blood crieth unto me from the ground.
    And now art thou cursed from the earth, which hath opened her mouth to receive thy brother‘s blood from thy hand;
    When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD‘s punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let‘s use the following function to describe their relationship:

技术分享

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3

Sample Output

6.889



题意:
一只吸血鬼,有n条路给他走,每次他随机走一条路,
每条路有个限制,如果当时这个吸血鬼的攻击力大于
等于某个值,那么就会花费t天逃出去,否则,花费1天
的时间,并且攻击力增加,问他逃出去的期望

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
//typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 20005

double dp[N];
int c[N];
int n;
int f;

double dfs(int f)
{
	int i;
	if(dp[f]>0) return dp[f];
	double ans=0;
	fre(i,0,n)
	 {
	 	if(f>c[i])
		{
			int t=(int)((1+sqrt(5.0))/2*c[i]*c[i]);  //大于c[i]时花的天数
			ans+=t*1.0/n;
		}
        else
			ans+=1.0/n*(1+dfs(f+c[i]));   //不大于c[i]时的天数
	 }
    dp[f]=ans;
    return ans;
}

int main()
{
	int i,j;
	while(~scanf("%d%d",&n,&f))
	{
		mem(dp,0);
		for(i=0;i<n;i++)
			scanf("%d",&c[i]);
		pf("%.3lf\n",dfs(f));
	}

  return 0;
}









ZOJ 3640 Help Me Escape(概率dp+记忆化)

标签:概率dp

原文地址:http://blog.csdn.net/u014737310/article/details/45177019

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!