码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2282-The Counting Problem(组合数学_区间计数)

时间:2015-04-22 09:44:41      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

The Counting Problem
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0‘s in the list, ten 1‘s, seven 2‘s, three 3‘s, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0‘, which is not considered as part of the input.

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247

题意:
统计从a数到b中,数过的数里面各个位置上0-9的个数。
分析:
从这道题上更体现了数学的魅力。。。
先不论哪个方法,都是找一个f(n),统计从1数到n的情况,然后再f(b)-f(a-1)出结果。

 递归的话就是建立f(k)和f(10*k+x)的关系,也就是说对于一个大数,先处理到末尾为0,然后再认为是从0开始10个10个数数到这个数。例如,f(2984)就先从2981数到2984(2,9,8各出现4次,1,2,3,4一次)然后f(2980)可以和f(298)建立递推(实际的时候用f(297)更好一点)。注意这里需要建立一个“乘子”,一开始为1,每次递推一层就*10,然后累加到0-9的记录上。
直接找的话是这样的,由于这个数n已经确定,所以在第i位上数字j出现的次数可以算出来,它是由第i位前面的数字f和后面的数字t决定的(f要乘以10的i-1次方,而不是i次方,因为相当于你把第i位去掉)。要考虑几个细节:数字j和n在第i位数字的大小比较;0的特殊性(首位不数);第一位和最后一位单独讨论(当数字只有一位的时候也要单独一下)。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
int res_a[10];
int res_b[10];

void get_res(int s,int res[],int t=1)//
{
    int i;
    int d,p;
    if (s <= 0) return ;
    d=s%10;
    p=s/10;
    for (i=1; i<=d; i++)
        res[i]+=t;
    while(p > 0) {
        res[p % 10]+=(d+1)*t;
        p=p/10;
    }

    for(i=0; i<=9; i ++)
        res[i]+=(s/10)*t;
    t*=10;
    get_res((s/10)-1,res,t);
    return ;
}
int main()
{
    int a,b;
    int i,j;
    while(~scanf("%d%d",&a,&b)) {
        if(!a&&!b) break;
        memset(res_a,0,sizeof(res_a));
        memset(res_b,0,sizeof(res_b));
        if (a>=b)
            swap(a,b);
            a --;
            get_res(b,res_b);
            get_res(a,res_a);
        for(i=0; i<9; i++)
            printf("%d ",res_b[i]-res_a[i]);
        printf("%d\n",res_b[9]-res_a[9]);

    }

    return 0;
}



POJ 2282-The Counting Problem(组合数学_区间计数)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/45176537

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!