码迷,mamicode.com
首页 > 其他好文 > 详细

Max Sum

时间:2015-04-22 11:36:55      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
//刚开始做这道题时理解错了,之后参考了别人的代码知道自己错那了,,之后还是出错,忘了考虑一种情况
如果是2 -8 9 18 -69 28输出结果应该为 28 6 6 但我的代码结果为28 5 6
#include<iostream>
#include<stdio.h>
int a[100000],min=-10000000;
using namespace std; 
int main()
{
	int t,n,max;
	int i,j,k,sum,s,e;
    cin>>t;
	
		for(i=1;i<=t;i++)
		{
			cin>>n;
			max=min;
			for(j=1;j<=n;j++)
				cin>>a[j];
			sum=0;
			k=1;
			for(j=1;j<=n;j++)
			{
				sum+=a[j];
				if(sum>max)
				{
					max=sum;
					s=k;
					e=j;
				}
				if(sum<0)
				{
					sum=0;
					k=j+1;
				}

			}
			printf("Case %d:\n",i);
			cout<<max<<" "<<s<<" "<<e<<endl;
			if(i!=t)
				cout<<endl;
		
	}
	return 0;
}

Max Sum

标签:

原文地址:http://blog.csdn.net/phytn/article/details/45192205

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!