码迷,mamicode.com
首页 > 其他好文 > 详细

(单调栈+二分) bzoj 1012

时间:2015-04-22 20:38:02      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

1012: [JSOI2008]最大数maxnumber

Time Limit: 3 Sec  Memory Limit: 162 MB
Submit: 4909  Solved: 2221
[Submit][Status][Discuss]

Description

现在请求你维护一个数列,要求提供以下两种操作: 1、 查询操作。语法:Q L 功能:查询当前数列中末尾L个数中的最大的数,并输出这个数的值。限制:L不超过当前数列的长度。 2、 插入操作。语法:A n 功能:将n加上t,其中t是最近一次查询操作的答案(如果还未执行过查询操作,则t=0),并将所得结果对一个固定的常数D取模,将所得答案插入到数列的末尾。限制:n是非负整数并且在长整范围内。注意:初始时数列是空的,没有一个数。

Input

第一行两个整数,M和D,其中M表示操作的个数(M <= 200,000),D如上文中所述,满足(0

Output

对于每一个查询操作,你应该按照顺序依次输出结果,每个结果占一行。

Sample Input

5 100
A 96
Q 1
A 97
Q 1
Q 2

Sample Output

96
93
96

HINT

 

Source

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
char opt[3];
int n,d,num[200005],stk[200005];
int main()
{
    int x,len=0,top=0,ans=0;
    scanf("%d%d",&n,&d);
    for(int i=1;i<=n;i++)
    {
        scanf("%s %d",opt,&x);
        if(opt[0]==‘A‘)
        {
            x=(x+ans)%d;
            num[++len]=x;
            while(top&&num[stk[top]]<=x) top--;
            stk[++top]=len;
        }
        else
        {
            int pos=lower_bound(stk+1,stk+1+top,len-x+1)-stk;
            printf("%d\n",ans=num[stk[pos]]);
        }
    }
    return 0;
}

  

(单调栈+二分) bzoj 1012

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4448490.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!