码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3065 病毒侵袭持续中 AC自动机模板题 ,,一A。

时间:2015-04-22 22:24:58      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:hdu3065   病毒侵袭持续中   ac自动机   bfs   

病毒侵袭持续中

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7685    Accepted Submission(s): 2687


Problem Description
小t非常感谢大家帮忙解决了他的上一个问题。然而病毒侵袭持续中。在小t的不懈努力下,他发现了网路中的“万恶之源”。这是一个庞大的病毒网站,他有着好多好多的病毒,但是这个网站包含的病毒很奇怪,这些病毒的特征码很短,而且只包含“英文大写字符”。当然小t好想好想为民除害,但是小t从来不打没有准备的战争。知己知彼,百战不殆,小t首先要做的是知道这个病毒网站特征:包含多少不同的病毒,每种病毒出现了多少次。大家能再帮帮他吗?
 

Input
第一行,一个整数N(1<=N<=1000),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在1—50之间,并且只包含“英文大写字符”。任意两个病毒特征码,不会完全相同。
在这之后一行,表示“万恶之源”网站源码,源码字符串长度在2000000之内。字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
按以下格式每行一个,输出每个病毒出现次数。未出现的病毒不需要输出。
病毒特征码: 出现次数
冒号后有一个空格,按病毒特征码的输入顺序进行输出。
 

Sample Input
3 AA BB CC ooxxCC%dAAAoen....END
 

Sample Output
AA: 2 CC: 1
Hint
Hit: 题目描述中没有被提及的所有情况都应该进行考虑。比如两个病毒特征码可能有相互包含或者有重叠的特征码段。 计数策略也可一定程度上从Sample中推测。
 
代码:
#include <cstdio>
#include <queue>
#include <cstring>
#define KIND 26
#define SIZE 2000100
using namespace std ;
int d[1010] ;
char t[1010][55] , des[SIZE];
struct Trie{
	int index ;
	Trie* next[KIND] ;
	Trie *fail ;
	Trie()
	{
		for(int i = 0 ; i < KIND ; ++i)
			next[i] = NULL ;
		fail = NULL ;
		index = 0 ;
	}
}*root;

void insert(char str[] , int index)
{
	int len = strlen(str) ;
	Trie *t = root ;
	for(int i = 0 ; i < len ; ++i)
	{
		if(t->next[str[i]-'A'] == NULL)
		{
			t->next[str[i]-'A'] = new Trie() ;
		}
		t = t->next[str[i]-'A'] ;
	}
	t->index = index ;
}

void bfs()
{
	queue<Trie *> que ;
	que.push(root) ;
	while(!que.empty())
	{
		Trie *now = que.front() ;
		que.pop() ;
		for(int i = 0 ; i < KIND ; ++i)
		{
			if(now->next[i] != NULL)
			{
				if(now == root)
					now->next[i]->fail = root ;
				else
				{
					Trie *p = now->fail ;
					while(p)
					{
						if(p->next[i])
						{
							now->next[i]->fail = p->next[i] ;
							break ;
						}
						p = p->fail ;
					}
					if(!p)
						now->next[i]->fail = root ;
				}
				que.push(now->next[i]) ;
			}
		}
	}
}

void query(char str[])
{
	int len = strlen(str) , i = 0;
	Trie *now = root ;
	while(str[i])
	{
		if(str[i]<'A' || str[i]>'Z')
		{
			++i ;
			now = root ;
			continue ;
		}
		int pos = str[i]-'A' ;
		while(now->next[pos]==NULL && now != root)
			now = now->fail ;
		now = now->next[pos] ;
		if(now == NULL)
			now = root ;
		Trie * temp = now ;
		while( temp!=root )
		{
			d[temp->index] ++ ;
			temp = temp->fail ;
		}
		++i ;
	}
}

void del(Trie *t)
{
	for(int i = 0 ; i < KIND ; ++i)
	{
		if(t->next[i])
			del(t->next[i]) ;
	}
	delete t ;
}
int main()
{
	int n ;
	while(~scanf("%d",&n))
	{
		root = new Trie() ;
		getchar() ;
		for(int i = 1 ; i <= n ; ++i)
		{
			gets(t[i]) ;
			insert(t[i] , i) ;
			d[i] = 0 ;
		}
		gets(des) ;
		bfs() ;
		query(des) ;
		for(int i = 1 ; i <= n ; ++i )
		{
			if(d[i]>0)
				printf("%s: %d\n",t[i],d[i]) ;
		}
		del(root) ;
	}
	return 0 ;
}

与君共勉

hdu 3065 病毒侵袭持续中 AC自动机模板题 ,,一A。

标签:hdu3065   病毒侵袭持续中   ac自动机   bfs   

原文地址:http://blog.csdn.net/lionel_d/article/details/45198975

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!