码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1331 Function Run Fun (基础记忆化搜索)

时间:2015-04-23 17:41:01      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:hdu   记忆化搜索   


Function Run Fun

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2602    Accepted Submission(s): 1263

Problem Description
We all love recursion! Don‘t we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
 

Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
 

Output
Print the value for w(a,b,c) for each triple.
 

Sample Input
1 1 1 2 2 2 10 4 6 50 50 50 -1 7 18 -1 -1 -1
 

Sample Output
w(1, 1, 1) = 2 w(2, 2, 2) = 4 w(10, 4, 6) = 523 w(50, 50, 50) = 1048576 w(-1, 7, 18) = 1
 

Source
 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1331

题目大意:如题

题目分析:对于有一个小于等于0的情况直接输出1,若有一个大于20,则搜索w(20,20,20),其他的直接搜w(a,b,c)采用记忆化搜索即可


#include <cstdio>
#include <cstring>
int const MAX = 60;
int dp[MAX][MAX][MAX];

int DFS(int a, int b, int c)
{
    if(a <= 0 || b <= 0 || c <= 0)
        return 1;
    if(dp[a][b][c])
        return dp[a][b][c];
    if(a < b && b < c)
        return dp[a][b][c] = DFS(a, b, c - 1) + DFS(a, b - 1, c - 1) - DFS(a, b - 1, c);
    else 
        return dp[a][b][c] = DFS(a - 1, b, c) + DFS(a - 1, b - 1, c) + DFS(a - 1, b, c - 1) - DFS(a - 1, b - 1, c - 1);
}

int main()
{
    int a, b, c;
    while(scanf("%d %d %d", &a, &b, &c) != EOF)
    {
        if(a == -1 && b == -1 && c == -1)
            break;
        if(a <= 0 || b <= 0 || c <= 0)
        {
            printf("w(%d, %d, %d) = 1\n", a, b, c);
            continue;
        }
        if(a > 20 || b > 20 || c > 20)
        {
            printf("w(%d, %d, %d) = %d\n", a, b, c, DFS(20, 20, 20));
            continue;
        }
        printf("w(%d, %d, %d) = %d\n", a, b, c, DFS(a, b, c));
    }   
}


HDU 1331 Function Run Fun (基础记忆化搜索)

标签:hdu   记忆化搜索   

原文地址:http://blog.csdn.net/tc_to_top/article/details/45222579

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!