码迷,mamicode.com
首页 > 其他好文 > 详细

Poj 2239 Selecting Courses 【二分匹配】

时间:2015-04-23 23:32:17      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:二分图

Selecting Courses
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9007 Accepted: 4010
Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects.

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him?
Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming’s college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.
Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.
Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3
Sample Output

4
题意:每一门课可能会在不同的时间不同的地点上,找出能看的最多的课程。
用map映射时间与地点,在套二分图模板即可。
代码:

#include <cstdio>
#include <iostream>
#include <map>
#include <cstring>
#include <vector>
const int M = 3e2+55;
using namespace std;

int n, mat[M];
map<int, int> m;
vector<int > Map[M];
bool vis[M];

int dfs(int u){
    for(int i = 0; i < Map[u].size(); ++ i){
        int v = Map[u][i];
        if(vis[v]) continue;
        vis[v] = 1;
        if(mat[v] == -1||dfs(mat[v])){
            mat[v] = u;

            return 1;
        }
    }
    return 0;
}

int main(){
    while(scanf("%d", &n) == 1){
        m.clear();
        for(int i = 0; i <= M; ++ i){
            vis[i] = 0; Map[i].clear();
        }
        int p, q, k;
        int t = 1;
        for(int i = 1; i <= n; ++ i){
            scanf("%d", &k);
            while(k --){
                scanf("%d%d", &p, &q);
                int temp = p*12+q;
                map<int, int>::iterator it = m.find(temp);
                if(it == m.end()){
                    m[temp] = t; ++t;
                }
                //printf("%d\n", m[temp]);
                Map[i].push_back(m[temp]);
            }
        }
        /*for(int i = 1; i <= n; ++ i){
            for(int j = 0; j < Map[i].size(); ++ j){
                printf("%d ", Map[i][j]);
            }
            printf("\n");
        }*/
        int ans = 0;
        memset(mat, -1, sizeof(mat));
        for(int i = 1; i <= n; ++i){
            memset(vis, 0, sizeof(vis));
            if(dfs(i)) ++ans;
        }
        printf("%d\n", ans);
    }
    return 0;
}

Poj 2239 Selecting Courses 【二分匹配】

标签:二分图

原文地址:http://blog.csdn.net/shengweisong/article/details/45228983

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!