码迷,mamicode.com
首页 > 其他好文 > 详细

Hdoj 4496 D-City 【并查集】

时间:2015-04-23 23:32:04      阅读:241      评论:0      收藏:0      [点我收藏+]

标签:水题   并查集   

D-City

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2134 Accepted Submission(s): 751

Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

Sample Output
1
1
1
2
2
2
2
3
4
5
Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

题意:输出删除前i条边之后有几个集合(块)
代码:

#include <cstdio>
#include <cstring>
using namespace std;
const int M = 1e6+50;
const int N = 1e5+50;

struct node{
    int x, y;
}e[M];
int n, m, fat[N], ans[M];

int fi(int x){
    if(x != fat[x]) fat[x] = fi(fat[x]);
    return fat[x];
}

void f(){
    ans[m] = n;
    for(int i = m-1; i >= 0; -- i){
        int x = fi(e[i].x), y = fi(e[i].y);
        if(x != y){
            ans[i] = ans[i+1]-1;
            fat[x] = y;
        }
        else ans[i] = ans[i+1];
    }
}

int main(){
    while(scanf("%d%d", &n, &m) == 2){
        for(int i = 0; i <= n; ++ i){
            fat[i] = i;
        }
        for(int i = 0; i < m; ++i){
            scanf("%d%d", &e[i].x, &e[i].y);
        }
        memset(ans, 0, sizeof(ans));
        f();
        for(int i = 1; i <= m; ++i)
            printf("%d\n", ans[i]);
    }
    return 0;
}

Hdoj 4496 D-City 【并查集】

标签:水题   并查集   

原文地址:http://blog.csdn.net/shengweisong/article/details/45228781

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!